Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 2 of 2      Prev   1   2
alekhka

Junior Member
Registered:
Posts: 15
Reply with quote  #26 
Thank you so much for your help! These frame markers are exactly what we needed.

On a note that is actually related to the thread title, we are now experiencing a minor bug where the first time we run a trial with movie and audio after loading multiple files, it seems like many of the audio files play at the same time. Quitting the trial and running again resolves the issue. We are loading the segments as individual conditions, each with a unique block number, where TaskObject 1 is the movie file and TaskObject 2 is the corresponding audio file. 

Thanks so much for your help!
0
Jaewon

Administrator
Registered:
Posts: 873
Reply with quote  #27 
Please explain what you did exactly. What do you mean by loading multiple files? Is that multiple timing files? Or multiple movies and sounds? How did you load them?

It sounds like you used the conditions file. If you put just 2 objects in each condition, how can you load multiple files?
0
alekhka

Junior Member
Registered:
Posts: 15
Reply with quote  #28 
Hi,

Sorry about the delay and the confusion. We are loading the files like this.
Condition   Frequency   Block      Timing File           TaskObject#1             TaskObject#2

    1           1         1        Movie_Timing       mov(vid/1.avi,0,0)        snd(aud/1.wav)
    2           1         2        Movie_Timing       mov(vid/2.avi,0,0)        snd(aud/2.wav)
    3           1         3        Movie_Timing       mov(vid/3.avi,0,0)        snd(aud/3.wav)
    4           1         4        Movie_Timing       mov(vid/4.avi,0,0)        snd(aud/4.wav)

Movie_Timing gets the IDs and plays them with AudioSound and MovieGraphic adapters. The file is based on what conditions number it is. Everything is perfect except that on first trial with first condition, many files seem to play together. But when the trial is closed and resumed, it corrects itself.
0
Jaewon

Administrator
Registered:
Posts: 873
Reply with quote  #29 
TaskObjects in each condition are created only when that condition is selected for next trial. So, in the way you defined, only one mov and one snd are created at a time.

You should show your timing script. Did you define stimuli in the conditions file and also create with adapters at the same time?
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.