Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
kms

Member
Registered:
Posts: 37
Reply with quote  #1 
Hi, 

With the new versions of Monkeylogic (21st & 23rd Dec. 2016), I am getting a skipped frame warning for some trials while the task is running. The warning tells me the no. of frames skipped as well as the time of skip during a given trial. My task displays only static stimuli (using crc, sqr etc.) not a movie or pre-defined image, so I am wondering what could be the source of the warnings and how can I fix it?

Thanks.


0
Jaewon

Administrator
Registered:
Posts: 730
Reply with quote  #2 
There are a couple of occasions that you may see the warning, even if all your stimuli are static. Are you showing the joystick cursor to the subject? Or are you calling reposition_object() or set_object_path() before idle()?
0
kms

Member
Registered:
Posts: 37
Reply with quote  #3 
I am showing the joystick cursor to the subject. Thanks.
0
Jaewon

Administrator
Registered:
Posts: 730
Reply with quote  #4 
The warning will be removed in the next version, if it is due to the joystick cursor update.
0
celia

Junior Member
Registered:
Posts: 9
Reply with quote  #5 
Hi Jaewon, 

I am getting similar warnings while my task is running. My task does play movie clips, but the errors appear so frequently (every hundred frames or so) that they pile up in the timeline on the right of the ML2 main menu: 
frameskip_error.jpg 

This pile-up appears to be slowing runtime and elongating ITIs considerably, ultimately causing the task to freeze after about 3 trials. Is there a way to disable this error message, or otherwise prevent it from slowing things down? 

----- 
Edit: I've checked a .bhv2 file, and it appears that in the field BehavioralCodes.CodeNumbers, the number '13' (the default code for 'Frame Skipped') appears every time a frame is skipped.

However, I'm not testing for visual perception (imperceptible frame skips don't don't affect my results) and I would rather not have these codes pop up. Is it possible to edit the default behavioral code file so that 'Frame Skipped' is no longer saved? 

0
Jaewon

Administrator
Registered:
Posts: 730
Reply with quote  #6 
Hi celia,

There are different reasons for getting the frame-skipped warning. 1) You may be testing in the simulation mode with one monitor, 2) the video memory is not sufficient enough or 3) the CPU is not fast enough.

Although it doesn't look pretty when the warnings are stacked up like that, their impact on the performance is not that huge. Elongated ITI sounds like movie creation takes too long, which means not enough video memory. You can try suppressing the warning, but I am afraid that it won't help.

To suppress the warning, open trialholder_v1.m and search the file with "if 0 < ml_skipped". It is around Line 336. Comment out all the lines between that if statement and the corresponding "end".

If you are running this on a laptop with Intel GPU, I would check how much memory is assigned for graphics on the BIOS. It should be the maximum (typically 1GB, recent systems can assign up to 2GB).

Stamping 13 is a tradition from the original MonkeyLogic. It will disappear if you comment out the if statement.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.