Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
fkchiang

Junior Member
Registered:
Posts: 6
Reply with quote  #1 

Hi Jaewon, 

I got an error message as below and it happened every time immediately after completed the first trial. It looks like that ML2 can not find "reward_dur" in TrialRecord structure. 

Another unusual thing in this case is that [V] option disappeared on the paused menu before ran the task.

Could you give me any thought about this to fix it? Thanks in advance.

Feng-Kuei

**** Error message from ML2 version (7.12.2017 build 83)
Error in RRRtask_runtime (line 1234)
reward_dur=TrialData.VariableChanges.reward_dur;

Error in run_trial (line 110)
runtime(MLConfig,TrialRecord,TaskObject,TrialData);

Error in monkeylogic/UIcallback (line 853)
result = run_trial(MLConfig,datafile);

Error while evaluating UIControl Callback.


0
Jaewon

Administrator
Registered:
Posts: 716
Reply with quote  #2 
The [V] option is not there because ML does not see any editable variable. Please check if there is anything wrong when you declare editable variables in your timing script.
0
fkchiang

Junior Member
Registered:
Posts: 6
Reply with quote  #3 

Thanks for the reply. We've fixed it but the issue is not from editable variables or timing file itself. Although we didn't exactly know what the bug is, we deleted the runtime file, moved the timing and condition files to a new folder then it works. I may look for the details later and figure it out soon. Thanks!

Feng-Kuei

0
Jaewon

Administrator
Registered:
Posts: 716
Reply with quote  #4 
Deleting the runtime and moving the files to a new folder are irrelevant to the problem. You probably created a new cfg file, when moving the scripts to a new folder, and that might fix the issue.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.