Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
em42

Junior Member
Registered:
Posts: 3
Reply with quote  #1 
I'm having trouble getting monkeylogic to recognize a parallel port.  I've tried the suggestions in the troubleshooting guide with no luck.  I'm running MATLAB 2013b and monkeylogic from April of 2014.  Is it possible that monkeylogic no longer recognizes parallel ports?  If so, has anyone found a work around to get eventmarkers to a plexon machine?
0
Edward

Administrator
Registered:
Posts: 245
Reply with quote  #2 
Good question. I also have some parallel port trouble. My ML does recognize it but says (not connected) beside the label. So I can't use it anyway. Do we need to do anything special, like install a driver?
0
Wael.Asaad

Administrator
Registered:
Posts: 51
Reply with quote  #3 
Have you guys tried the "daqregister" command?  I believe the syntax is something like "daqregister('parallel')" - or something along those lines?
0
Jaewon

Administrator
Registered:
Posts: 716
Reply with quote  #4 
You may need to run MATLAB as administrator not only for the 'daqregister' command but also for general access to the parallel port, since MATLAB tries to install and start a parallel port driver every time. Some people have this problem only on 64-bit Windows. Microsoft does not provide a parallel port driver for 64-bit Windows, so 64-bit Windows is more likely to have issues with parallel-port-accessing applications. See if following two commands run on your MATLAB with no error.

daqregister('parallel')
daqhwinfo('parallel')
0
em42

Junior Member
Registered:
Posts: 3
Reply with quote  #5 
Thanks for the quick responses!

Run as admin, on 64-bit windows, It looks like daqregister is running fine, but I got an error for daqwinfo.  As Jaewon suspected, it looks like MATLAB is having difficulty booting up the driver.  Is there a workaround for this?

>> daqregister('parallel')

ans =

'mwparallel.dll' successfully registered.

>> daqhwinfo('parallel')
Error using daqhwinfo (line 122)
Could not get information for parallel. PARALLEL: Could not start the WINIO.SYS device driver.

0
Edward

Administrator
Registered:
Posts: 245
Reply with quote  #6 
I got the same error as em42.

I am running 64Bit Win7, and my user is designated as an administrator.
0
Jaewon

Administrator
Registered:
Posts: 716
Reply with quote  #7 
I am developing a new DAQ toolbox that can solve all known issues. It supports parallel ports (on-board and PCI types) on both 32-bit & 64-bit MATLAB. Let me know if you are interested.
0
em42

Junior Member
Registered:
Posts: 3
Reply with quote  #8 
That sounds excellent, definitely worth a try!  I'm using 32-bit MATLAB currently.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.